Omron FINS driver connection


I have an Omron CJ2H I am trying to connect to via Ignition using the Omron FINS driver. I have tried both TCP and UDP, how do I know which one to use?

UDP shows unbound no matter what I do, with TCP I am able to get the device to show connected, but when trying to get a Boolean to map across, it always shows bad quality. My device connection settings in the gateway are all default for TCP.

The tag I am trying to monitor is this one:

And I am using this address:

I tried changing it from 3.02 to just 3 and changing the type to Int16 but I still get bad quality.


I was able to get the UDP connection to show BOUND finally. Now I still have the same issue with addressing tags.

Try using WR3.2 as your address.

I’d also switch back to the TCP driver. You were able to get that connected, which means your device is likely set up to accept FINS TCP.

UDP is connectionless and being “Bound” means nothing more than you were able to bind to the local address on your server. You could be sending UDP packets into the void and never know if there’s something on the other end actually configured to listen or if your requests are timing out for some other reason.

Hi Kevin,

Thanks for the reply. I switched it back to TCP, and configured the address as shown:

I tried:


But it returned bad quality each time.

You can try setting the logger level for the logger you get searching “FinsReadRequest” to TRACE and see if anything useful shows up in the gateway logs. See Diagnostics - Logs - Ignition User Manual 8.1 - Ignition Documentation

If it’s just a timeout then you probably don’t have the right connection settings or something in the PLC isn’t set up correctly.

The address looks fine though, so not sure what else it would be. I do normally recommend testing in the Designer by manually creating an OPC tag and not using any kind of address mapping until you’ve managed to get valid data into the test tag.

Ok, I’ll check it out. Thanks for the feedback.

Activating trace logging revealed my embarrassing mistake. The reason for the bad quality was due to the module not being licensed and the trial expired. I reset the trial and everything works like it should. Thanks for your help.

1 Like