Only execute group once when trigger is active

I’ve had a strange issue on a group trigger setting that I need to get resolved. Sometimes after restarting the FSQL service, the checkbox for “Only execute group once when trigger is active” is not selected. The checkbox was selected before the restart. This has happened a few times and I do not catch it until a db table is filled with data. Depending on the update rate of the trigger, the MySql table can fill up very quickly. This is the only group selection that seems to change and it has happened on different groups.


What version of FactorySQL are you using? Does it tend to only happen when you have recently stopped/started the group, or at any time?


The version is The problem only occurs when the FSQL service starts up automatically, say after a reboot/restart of the server.


Ok, I would recommend upgrading to the latest version, there was a bug fixed in 4.2.8 that pertained to group settings being lost. We haven’t got a report of this in a long time, so that should likely be the bug you’re running into.

If upgrading isn’t an option at this moment (due to production schedule, etc), when you modify the group, click off of it, then back on, and make sure it’s set. Then start the group. Also, make sure no groups are selected if you happen to go into Settings. I believe this problem was caused by setting a value, then immediately clicking “start”. The group would start with the setting, but in certain cases (depending on how the group was de-selected), the old setting would get saved. Thus on restart, the old setting would be used, which is what you’re describing.

Hope this helps,

I just finished upgrading to the lastest version on both of our servers. After restarting the service, I didn’t have any issues with any of the group trigger settings. Hopefully that should fix this issue. Thanks for the explanation.