OPC Client Connection

I’m using Ignition 8.0.4, and trying to add a third party OPC Server to the gateway. Under configuration -> OPC Client -> OPC Connections I click create new connection. I select OPC UA, then I type in the end point host and port. I click next, then I see Internal Server Error. I looked in the logs and see this error:
org.apache.wicket.WicketRuntimeException: Expected to find in base markup: jar:file:/C:/Program%20Files/Inductive%20Automation/Ignition/data/jar-cache/com.inductiveautomation.opcua/__1026606207__opc-ua-gateway-8.0.4.jar!/com/inductiveautomation/ignition/gateway/opcua/client/connection/web/discovery/wizardsteps/AbstractDiscoveryWizardStep.html

I tried the same settings to try to add a second copy of the local ignition server, by specifying localhost, and had the same error. I am able to click the Advanced Configuration and add the host that way, but not through the discovery service.
Is there a way to get the discovery service web page to load/work, does anyone else have this problem? I tried this on Ignition, and Ignition Edge.

What are you typing in as the endpoint URL?

I am connecting to a demo kepware server with the endpoint url here: opc.tcp://
I am successfully connected to the OPC UA Server using the UaExpert OPC Client.

I can also get the same error, if the Ignition OPC UA Server is bound to localhost, and type this in the endpoint url: opc.tcp://localhost:62541/discovery

There might be something wrong with your OPC UA module or the way it was packaged… not sure. You’re using correct endpoint URLs. Let me know if upgrading to 8.0.5 doesn’t fix this.

I just installed 8.0.5, and have no problems, it works very well.