Opc da 7.3.1

Normally, starting the gateway launches the OPC DA server. However, since upgrading to 7.3.1 the OPC DA launches, as shown in the task manager, but there is no tab in the task bar to view the app. Was there any changes to the OPC client or licensing? In the past there was a timing issue when starting the OPC server due to the trial license. After the permanent licenses were installed it worked ok till this last upgrade.

Starting the Ignition gateway has never been tied in any way to the launch of a DA server, at least not directly.

The only thing I can imagine happening is that upon receiving the first COM connection attempt from Ignition, your DA server was doing something, and now it’s not.

Ignition is still doing what it always did - trying to connect.

Yes, Kevin’s correct, in that the opc server launch is simply the result of us connecting. And nothing has changed in this regard for 7.3.

However… it’s possible that the upgrade might have inadvertently modified the settings of the Ignition Windows Service, which could have implications for DCOM and in turn OPC. Do you remember if in order to get Ignition to work with the server the first time you changed the service settings? Mostly likely you would have enabled “allow interaction with interactive session”, and you might have change Ignition to run under a user account, instead of system.

You can check these systems by going to Control Panel>Administrative Tools>Services, right-clicking on Ignition, and selecting “properties”.


Precisely correct! Enabled “Allow services to interact with desktop”. Now it works ok. Thanks