OPC Server Falted, Timing out


I’m trying to find anything related to the following issue but so far no answer. Were working on a standalone PC/server with which is running ignition. We added the CompactLogix device on ignition, but, even though the status said Connected, we couldn’t see any tags. Next, we checked the status of out OPC Server and it was Faulted. I do believe this OPC server was set up automatically (I wasn’t present during the installation), but to be sure we opened the End Point window using localhost the options that pop up are on 169.* address. Both the ignition PC and PLC are on a 192.168.1.X network. The web portal also works when using 192.168.1.X address.

Furthermore when we check the status of the OPC server it seems to be pointing at a 169.* address and timing out. I’ll try to add more details on this, but I’m hoping that someone can figure out what might be the issue with the information I’ve share so far.

Thanks in advance.


169.* addresses are APIPA numbers used when a machine cannot reach a DHCP server and there’s no manual IP address configuration. This can mean your Ignition service was configured when your network wasn’t plugged in or your DHCP server was slow to respond. You’ll have to manually configure that endpoint to your Ignition gateway’s actual address.


Thank you for your response. I checked online the process to manually configure the server, but it seems similar to what we did. When we got to the Endpoint window we entered opc.tcp://localhost:4096 and hit discover. Both options show a 169.* address as well. Is there another process to manually configure the server?


First thing, you should check the Ignition console to make sure the reason for the fault isnt something simple, like “BadUserAccessDenied”, etc.

That being said, I’ve had fault problems come up when I reconfgure a static interface. You can try directly using the Ignition PC’s IP, instead of localhost… i.e tcp://<>:4096.


I’ll check the above statement.

I have tried entering the PC’s IP address instead of localhost, but when I click Discover I don’t get any results.


[quote=“JM_PEREZ”]… but when I click Discover I don’t get any results.[/quote]I’m confused.
Why are you using the discovery tool when you know the IP address is static? Just put in the 192.168.1.x address that you’ve configured the server to always have.


This pretty much fixed it, the only step I missed was rebooting after I entered the IP address and saved it.

Thank you and everyone for your help!