OPC UA Allenbradley driver read timeout

I have now setup the Control Logix L61 CPU with a Ethernet Card.
Ignition is cummunicating with the PLC, however i get a lot of warning messages about timeouts on tag reads.
I have increased the timeout times without any luck. it is continuously displaying timout errors, at least 1 every minute.
Any ideas on how to fix this.
Settings on the driver are:
Device Name: MixTanks
group: default
Browse Timeout: 240000
Read Timeout: 60000
Write Timeout: 30000
Enable Device: checked

Communication timeout: 3000 (i have tried larger values here as well)
Browse cache Timeout: 0
Slot number: 0
Connection Path: (Left Blank)
Concurrent requests: 50 (have tried smaller values with worse outcome)

Any help here is appreciated.


The communication timeout is the value that effects the timeouts you are describing.

Also, 50 concurrent requests is likely much too high. How many tags are you subscribing to? How many requests are there total? You can find this information on the diagnostics page for the device you are talking about in the Ignition gateway.

There were about 4000 or more tags in the system.
I have reduced that to about 2000
The first messages that appears is:
Message arrived for key “0” but no request found.

Then after that all items on the screen turn red for about 10 seconds.
They reappear normal then for about a minute. then 1 item will not read randomly. after a while the whole screen turns red again. (Tag driven items).
I have setup the tags to be Direct at a rate of 3000ms.


Is the Main task in the PLC continuous or set at some fixed interval?

If it is continuous, the default time slice given to I/O may be too small to accomplish what you want.

Our AB guru told us about a system he saw that had lots of PanelView Plus on it (30 or so). They were having slow response times to button presses on the PVs.

The Main PLC task was continuous. Changing that solved the problem.

The moral is, All your problems may not be in Ignition.

I hope this helps.


Can you email your wrapper.log files to support? You can find them in the Ignition install directory. Just zip them up and don’t worry about the size; zip compresses them pretty well.

Hi I have sent the Wrapper log files.

I have played around with the tags further.
I have set them to leased slow rate 6000ms fast rate 1500ms.
I noticed on the OPC Status page that all the items under the slow rate have data = “null” and Quality = “No Data available”.

Thanks in advance.

Hi Gents,

I have also tried changing the MainProgram group from continous to intervals of 100ms in the PLC.
The problem still persists.
There is no other connections being made to this plc apart from the ignition hmi itself.


Any other tasks in the PLC running continuous?

No only one task in the PLC Which has a few valve and motor blocks in it.

Hi Gents,

Any update on the driver update that is required for this problem, this system is going into production soon and this connection timeout causes some issues.


There was a 7.2.6 beta posted last night that has some changes to address the key = 0 messages, you should give that a try and see if it improves things.

Hi Kevin,

i have tried the new 7.2.6 beta version and it seems to fix the problem. Thanks guys.
You all do a great job.

Just for yourselfs i have seen a new error in the AB driver to the same PLC.

com.inductiveautomation.ignition.gateway.web.pages.config.systemconsole.LogViewer$SerializableLoggingEvent$ClonedThrowable: null
java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
java.util.concurrent.FutureTask.runAndReset(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)

Hope this helps if you need anything else just drop me a line.

Please send the wrapper log containing that error message if you can. Unfortunately our gateway logs leave out some of the more vital parts of stack traces right now. Carl is actually working on rewriting that console/log viewer as I type this…

Edit: Actually I think there’s enough information in the stack trace to figure it out. Thanks!

Edit 2: It looks like that error shouldn’t have actually affected anything but the diagnostics calculations. Communications to that device should have continued uninterrupted. Can you confirm that’s the case?

That is correct, communications did stay up!

Hope this helps.

Any idea when the full version of 7.2.6 is coming out.


Any update on the 7.2.6 release? I’ve been hesitant to install the beta version.