OPC UA ControlLogix Tags Missing (Some there, some not)

I have created a new device in OPC UA to a ControlLogix PLC. The device conencted and some tags will browse, but not all. No amount of time seems to bring the missing tags in. Tried refresh, no help. Tried restarting Ignition, no help. I can see all tags when browsing with RSLinx. I tried creating a new tag that I could see using browse and that was fine. I then tried to create a new tag to a known good tag (that wouldn’t show up in browse) and it never would come out of “stale”.

Please Help!

Please let me know:

  • Which ControlLogix processor are you connected to?
  • What ControlLogix firmware are you using?
  • Which version of Ignition are you using?

With the ControlLogix processor, typing in an address that doesn’t appear in the browse results will not work.


Processor: L55-M13 (Redundant Configuration) via 1756-ENBT
Firmware: 15.60
Ignition: Latest (general release) 7.4.2 (b953)

On the address, yeah, I didn’t think it would, but there are several tags that are in the PLC (both Global and Program) that just don’t show up. All browse with RSLinx just fine.

If I remember correctly with the ControlLogix redundant configuration, the tags that are shared among the two processors will not show up in Ignition.

NO, There is no “tag sharing” going on. Only one processor is ever being looked at at any given time. The tags are only in one processor. The communication driver (whether RSLinx or something else) doesn’t even know that there is a redundant situation going on. The communication driver is just looking at an IP address, the redundancy hardware swaps IP addresses on the ethernet modules during a changeover. There is something else wrong here.

We really need to solve this issue, I have a project to implement that will be using thousands of tags from this PLC.

Please help to get this working correctly.

Ok, I’m thinking of the GuardLogix.

Because the problem of tags showing as folders has been intermittent, we have not narrowed in on the source of the problem. But, we are still focusing on it.

Currently, this may help:

  • Restart OPC-UA
  • Delete the /data/drivers/.tags file on the Ignition server.
  • Refresh Browse for the device (not in the OPC Browser)

If you have the time, call into tech support when it happens. We are unable to reproduce it in-house and it will be a big help.

Thank you,