OPC-UA Driver Bridging DH+ and ControlNet to PLC5

I have a PLC5 processor with both ControlNet and DH+. I am able to bridge DH+ to the PLC5 processor from a ControlLogix rack, but am having issues trying to bridge to it from another ControlLogix rack with ControlNet.

In the successful DH+ case, I have:

Rack 1:
Slot 12 – 1756-ENET/B
Slot 8 – 1756-DHRIO/B, DH+ Node 3

Rack 2:
PLC5, DH+ Node 10

I can use the PLC5 Driver with the ENET card IP Address along the with connection path 1, 8, 2 , 10 where:
1 - backplane
8 - DHRIO Slot Number in Rack1
2 - DH+ Channel of DHRIO Card
10 - DH+ address of Controller in Rack 2

In the unsuccessful ControlNet case, I have:

Rack 1:
Slot 9 – 1756-ENBT/A
Slot 2 – 1756-CNBR, ControlNet Node 17

Rack 2:
PLC5, ControlNet Node 4

I’m trying to use the PLC5 Driver with the ENBT IP Address along with Connection Path 1, 2, 2 , 4 where:
1 - backplane
2 – CNBR Slot Number in Rack1
2 – ControlNet Channel of CNBR Card
4 – ControlNet address of Controller in Rack 2

I can create a DDE/OPC topic in RSLinx using the ControlNet path and read data. I believe it comes up with the same path I’m using.

Do I have something wrong with the ControlNet connection path? Is this possible?

Which version of Ignition are you using? We fixed a bug for ControlNet connection paths in version 7.1.7.

Also, In the example that you are giving you also have to tack on 1, to the end. It continues the route to the backplane and then to the slot of the processor.
For example:

If the processor is in slot 0, then 1, 8, 2, 10, 1, 0 for the DHRIO.

And 1, 2, 2, 4, 1, 0 for ControlNet


I tried 1, 2, 2, 4, 1, 0 path for ControlNet and it still doesn’t work. The status alternates between connecting and disconnected.

I didn’t think you needed the 1,0 at the end of the path because I tried DH+ without it first and it was fine - it works. The other reason I didn’t think so is the ControlNet node is on-board the processor and I thought always needed to be in the first slot for PLC5, but its been a while. For a test with DH+ I did add the 1,0 to the path as you directed and it does still work.

So with DH+ it works both ways and ControlNet doesn’t work either way.

I tried on 7.1.8 (b6247) and the latest development build, 7.1.9-beta2 (b6361).