OPC UA Failover Not Working

Hi all!
I have 2 PC with redundant ignition OPC UA servers(the master is and the backup is I have a 3rd PC with ignition getting data from these redundant ignition servers via opcua. When I test stopping the master gateway, the redundancy works and all my data are still alive for the client.

However on my 3rd PC, the opcua server connection becomes faulted. I have configured failover and I am expecting that when the primary opcua server becomes faulted, it will try to connect to the failover endpoint server. But when I check the logs, it keeps on trying to connect to the primary only. It does not switch on connecting to the failover.

UaException: status=Bad_ConnectionRejected, message=java.net.ConnectException: Connection refused: no further information: /
at org.eclipse.milo.opcua.stack.client.UaTcpStackClient.lambda$bootstrap$15(UaTcpStackClient.java:510)
at io.netty.util.concurrent.DefaultPromise.notifyListener0(DefaultPromise.java:683)
at io.netty.util.concurrent.DefaultPromise.notifyListeners0(DefaultPromise.java:604)
at io.netty.util.concurrent.DefaultPromise.notifyListeners(DefaultPromise.java:564)
at io.netty.util.concurrent.DefaultPromise.tryFailure(DefaultPromise.java:425)
at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.fulfillConnectPromise(AbstractNioChannel.java:276)
at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:292)
at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:545)
at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:485)
at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:399)
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:371)
at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:112)
at java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: no further information: /
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(Unknown Source)
at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:224)
at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:289)
… 6 more

7.9.9 (b2018081621)
Oracle Corporation 1.8.0_181

I also created a separate opcua server for the master and the backup on my 3rd pc just to ensure that I can connect to them properly and yes, I have good connection to them.

I have seen a very similar scenario in this forum OPC Server Connection Redundancy Settings, however, his solution did not work for me.

Maybe I am missing something. But I already tried different combinations of enabling the backup and the failover but to no luck. I hope you can shed some ideas on how I can make this work.

I am using Igition 7.9.9

Thank you so much in advance.

The failover threshold of 100 may have something to do with it.

Hi. Thanks for responding. It was originally 5. I changed it to 1 and 100 to see if this might help me resolve the issue. But no luck still. Hope you can advise me of what more I have to configure to resolve this. Am I missing something? Thanks.

The threshold should go back to default.

I think the endpoint failover endpoint URL might be incorrect… when you do discovery I think you get something at the end like /iaopcua, and that needs to be included in the setting here or it won’t match up.

I tried it also but the connection is still faulted. I tried other combinations but the connection remains faulted. I hope you can advise me on other configuration that I’m probably missing. Thanks.

I am having the same issue here. I have 2 ABB PLCs with OPC UA built in.

I am able to connect to them individually. I did have to add the Host over ride to get the connections going when connecting individually.

However I am unable to get the fail over working.

Any ideas are welcome.
Thanks in advance

system_logs_31Jul2019-16-15-38.zip (2.2 MB)

Has this been resolved? I’m experiencing this issue with 7.9.12