OPC-UA no longer works

This worked before, but not anymore. What is wrong?

Could not open secure channel to opc.tcp://169.254.95.120:4096/iaopcua/Basic128Rsa15


com.inductiveautomation.opcua.UAException: Could not open secure channel to opc.tcp://localhost:4096/iaopcua/Basic128Rsa15.
com.inductiveautomation.xopc.client.stack.TCPClientChannel.open(TCPClientChannel.java:265)
com.inductiveautomation.xopc.client.stack.UaClient.connect(UaClient.java:65)
com.inductiveautomation.xopc.client.OpcUaConnection.verifyConnectionState(OpcUaConnection.java:147)
com.inductiveautomation.xopc.client.FailoverAwareOpcUaConnection.verifyConnectionState(FailoverAwareOpcUaConnection.java:75)
com.inductiveautomation.ignition.gateway.opc.OPCManagerImpl$ServerWrapper.verifyConnectionState(OPCManagerImpl.java:743)
com.inductiveautomation.ignition.gateway.opc.OPCManagerImpl$OPCConnectionKeepalive.run(OPCManagerImpl.java:619)
com.inductiveautomation.ignition.common.execution.impl.BasicExecutionEngine$TrackedTask.run(BasicExecutionEngine.java:573)
java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)
java.util.concurrent.FutureTask.runAndReset(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source)
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)java.lang.Thread.run(Unknown Source)

Can you post your logs? What changed? That IP address looks pretty suspicious…

that is not an ip on our network. This worked in the past but I don’t know that this has worked since the upgrade to 7.6.x.

how do I get a log for you?

On the console page there’s an export link that will give you a logs.bin.gz which you can email to support.

But it’s probably not gonna be that helpful.

Check that the IP address in the OPC-UA > Settings > Endpoint Address matches the IP of the machine your gateway is on, and then the IP address for the connection under OPC Connections > Servers matches as well.

If you have to change the Endpoint Address you’ll need to restart the UA module for it to take effect.

An IP address starting with 169.254 is a link-local ip address. Essentially, you don’t have a static IP address, and you don’t have access to a DHCP server. My guess is that the ip address that the computer assigns itself has changed. If you are completely stand alone, or require no external OPC access, you should probably set the OPC server host setting to the loop-back adapter IP address, which is 127.0.0.1.

Also, if you need help sleeping, here is the RFC for the link-local IP address scheme
RFC3927

127.0.0.1 has replaced local host,

restarted module - faulted
restarted gateway - faulted

I wish I could upload pics of my settings.

com.inductiveautomation.opcua.UAException: Could not open secure channel to opc.tcp://127.0.0.1:4096/iaopcua/Basic128Rsa15.

Refresh certificates.