OPC-UA server behind NAT


I have one Ignition into a LAN reachable via NAT, this mean that ignition IP is but to connect to it from outside the IP is…

I have created the NAt rule according but once i try to connect to it from other ignition i see that the response endpoint is

I have changed into “OPC-UA->Settings” the Endpoint Address, and i have rebooted the module first, and later the complete PC to check because i am obtaining the bad endpoint from Ignition OPC-UA.

But i still obtain the bad endpoint from the server.

Anyone knows how to do this??

Don’t try to get the server to return in the endpoint URL.

Instead, set the “Host Override” setting for the client connection to



Thanks, it works now!

Muchas Gracias!!

I recognize this post is very old but I'm attempting to do the exact same thing and I'm looking for some clarification. The physical address of my device/OPC server is opc.tcp:// This is behind a NAT with the WAN set to another network (say 192.168.x.x).

So for the Endpoint URL I would put opc.tcp:// and for the endpoint host override I would put in just the WAN IP address of 192.168.x.x or I would put in opc.tcp://192.168.x.x:4840/discovery?