OPC-UA Server connected but tags in the Designer stills show Uncertain_LastKnownValue

I get the issues with the ignition 8.1.1 every time I using ignition after turn on my laptop. OPC-UA connected to PLC via ModbusTCP and I can check the tag value by OPC Quick Client. But that tags in the Designer still show Uncertain_LastKnownValue. Each time get issue, I must be restart OPC-UA module.
So, please help me to resolve this issues.
(The same issues with Ignition 8.0.16, 8.017 and 8.1.0

1 Like

Is there another device also trying to connect to that modbus device on the same port?

Device only connects to laptop (direct connection). I tried with three different laptop but still get the same issues.

I’m getting the exact same problem. Tags all show up in the OPC browser. Device connection is “connected”. But tags all say Uncertain_LastKnownValue. No other devices except the host PC and the target A/B L33ER (v32). Restart the OPC_UA module and it all comes back to life.

I found another things, that problem does not only occur with the real device but also with the Programmable Device Simulator.

I’m running 8.0.15 and I just stumbled upon this exact problem, all my 30+ Modbus devices showing “Uncertain_LastKnownValue”.
Additional data: Besides those modbus devices, I have 6-8 S7-1500 PLCs which had no connection issues.

I’m going to try to restart the module

EDIT: Restarting the module helped to restore communications.

1 Like

I had the same issue with a template, I had to restart everything including my machine and it fixed it.

Did you try restarting only the module? it’s easier than restarting the whole gateway

I have the same problem. Once I restarted the OPC-UA module it cleared.

1 Like

Same here. Im using Omron FINS/TCP driver with ignition edge 8.0.16.

Im wondering if there is a relation to the sequence of starting up?
I.e if gateway is first up, then only plc is connected/online, somehow the problem is triggered? But not all the time…

Because for my case, the problem only exist during the first startup of the gateway/pc, once in a while…

See Edge OPC UA Omron FINS/TCP connection, tag status showing uncertain - #4 by Kevin.Herron