OPC-UA Server invalid CD-Key

Aw snap!

Tried with 2 different OPC-UA licenses (one generated today)

v7.7.0, Java 8u20, both 32-bit.

Tried one from a running system and it went to an emergency activation, so I know it will accept some sort of key… :laughing:

I was wondering if the License generator hasn’t caught up to 7.7 yet…

Quick update:

Unactivated one from a current 7.7 OPC server and activated okay on my problem child. So I’m guessing it’s not a 7.7 issue or generator issue per se.

Would it have anything to do with sending the email to my home account instead of work? It’s just that our corporate server refresh rate can be agonizingly slow… like a whole ten minutes minutes! How can I satisfy my inner impatient child? :laughing:

I ask because both of the inop keys were sent to my home account.

Quick update 2:

Had a key sent to my corporate email. And after my coffee, it showed up in my inbox. Tried it out on the problem child-- and still no go. :cry:

I don’t have any immediate answers to why this happened, but if you email in the CD-keys to the support inbox (put “attn Paul” in the subject) I can investigate the issue on our end.

Thanks, Paul. Likely to be Monday. I’m getting sleepy!

Okay, for those playing along at home, the issue was the license generator creating numbers with invalid characters. I was just incredibly lucky enough to get three invalid ones within a two week period-- two on the same day!

The license generator should be fixed up now.