OPC UA Server - Read/write wrong datetime

Hi,
I’m using Ignition 7.9.14 to try to read and write some tags from a PLC SIEMENS Simotion using the opc ua connection. I’ve configured everything in ignition gateway and I can correctly read/write all available data except for datetime types.
It seems that opc server reads a datetime shifted by two hours. I’ve already tried to change the type of the tag in ignition but I have always the same data.
I’ve also tried to use an external opc client (Ua Expert) and with the same configuration when i tried to read the tag with the datetime, the opc client reads correctly.
I’ve already checked the timezone and datetime of the gateway and of the pc and both are correct.

For example, as you can see in the screenshots, the external opc client reads ‘2020-08-06 8:38:23.000’ , instead ignition reads ‘2020-08-06 10:38:23.000’Screenshot_4

Could you please help me to solve this problem?
Thanks.

Ignition is displaying the time in your local timezone, UaExpert is displaying it in UTC (that ‘Z’ at the end is for ‘Zulu’).

There is no room for date/time translation errors in OPC UA. All date/time values are transmitted in UTC, so if something is amiss then either the PLC is sending the wrong value or your timezone settings on the gateway aren’t right for some reason.

Based on the “Timestamp” value, you appear to be in CEST timezone, which is UTC+2, so the time you see in “Value” is the same as the “Value” you’re seeing in UaExpert.

1 Like

Hi,

Recently i have encountered the same issue. Ignition version is 8.1.17

In PLC(S7-1515):

In OPC Quick Client:
image

Gateway Timezone:
image

PLC Timezone:

Could you please help me out where it’s going wrong.

Thanks In Advance

If setting the timezone was done recently on either of these I’d try restarting (restart Ignition server, download and recompile the PLC program).

If that doesn’t work still, get a Wireshark capture and we’ll see what the raw value the server is sending is.

Something seems strange to me, though, because your Gateway Timezone is supposedly UTC+1 but the timestamp from the Quick Client displays CEST, which is UTC+2. Could be that you need the gateway server restart.

For now we have adjusted the PLC time as a temporary fix and meanwhile we are trying for NTP Synch. I will do restart when we are taking trails with NTP. Thank you for your support