Open popup on tag

I have the config from the photo…and i want to show that popup when my temp reaches 30 degrees…it should work…but it doesn t. in the photo the server isn t connected, but it doesn t work even when i connect it.i can t even open a warning window…any help?

Tag Event scripts are run on the gateway, the gateway cannot open windows on the client. You need to write a script in Project - Client Event Scripts - Tag Change.

1 Like

It worked…thank you!!
Now i have another problem… i’m trying to access the app from my phone…but it doesn t work…and i have disabled firewall from my pc…

You need to have the mobile module installed and enable mobile launch in the project properties. Then launch it by browsing to the gateway website and clicking the link for Mobile Launch. If you cannot browse to the gateway webpage then you have network connection issues.

how i install mobile module? and enable it?

I recommend you check out inductive university, it has a section on installing modules: Installing or Upgrading a Module - Installing and Upgrading Ignition
Once you’ve installed it, enable for your project here:

Then it should show on the main gateway webpage to be launched from your mobile browser.

The module is installed and is enabled…still doesn t work

it is showed on the gateway page…but when i scan the qrcode…simply doesnt work…

“localhost refused connection”

Your gateway is not putting its own name in the url embedded in the QR code. That usually means your DNS and/or hosts file is not set up correctly. What do you get when you run this at a command line on your server:

hostname -f

Alternately, populate the ‘Server Address’ field in the mobile settings:

Note that this won’t necessarily fix any other issues with the mobile module’s configuration, but will at least fix the QR code/hyperlink on the main page.

1 Like

Where exactly i found “Server address”…mobile settings?

My server is on raspb pi…i should write its ip, or the ip from the computer where my gateway is?

You would enter whatever IP address or hostname is being used by your client to reach the gateway.

i’ve already did it…still no luck…

I am not sure the mobile module will work on a Pi. I do not think you would ever be able to support mode than a client, if you are lucky.

There is additional configuration for using the mobile module on Linux. Good luck.