Out of Memory in Ignition

Hi I have a problem with my Igniton aplication, in first i’configuring a new device but even i create it y doesn’t save. The system console of Ignition says me that is a problem of out memory error.
Also i tried to put another backup maybe to solve the problem but it doesn’t let me to restore a backup also.

it says out of memory again.

Help me please :frowning:


Well, you are out of memory. You can increase the amount of memory Ignition uses by doing the following:

  1. Open the ignition.conf file located in c:\program files\inductive automation\ignition\data
  2. Find the line that reads:wrapper.java.maxmemory=10243)Change the 1024 to something higher. Keep in mind that a 32bit installation of Ignition has a max of 1200-1500 MB or so. You can use anything on 64bit.
  3. Save the change and restart Ignition service.

Let us know if you have further problems.

Hi, thanks for the response

I tried what you said and I still have problems, new problems by the way

1.- my system is an 64 bit on a windows server 2008 and i tried first to put (3072) of memory and after the service gets stopped and i doesn’want to start again . I tried to start by the Ignition Gateway Utility, after i try it shows me an number help NET HELLPMSG 3547 and that a service error ocurred.

to fix it i tried to put again how was at the beginning with 1024 and almost with it the service is fixed but my problem of memory stills there

i tried one more with less memory (2048) and happened again, the problem with the service that is stopped and doesn’t want to start.

what i can do about this.

Please help me :frowning:


I see. That is because I bet your ignition.conf file is trying to use a 32 bit Java (JRE). Open the ignition.conf file again and look for the line:wrapper.java.command=C:\Program Files (x86)\.....\java.exeI bet it has the x86 in the path. That means it is pointing to a 32bit Java. To fix it:

  1. Make sure you have a 64 bit Java installation
  2. Set the line to:wrapper.java.command=C:\Program Files\Java\jre6\bin\java.exeor whatever you 64bit Java path is.

Having the same problem on a backup redundant server with a 64-bit install of Ignition and Java (no 32-bit JVM even present!). Same error messages shown in the second post’s screenshots and no gateway start. Master server is same hardware/software config and not exhibiting any of these problems.

I tried a reinstall (forgot to deactivate… thanks Jim! :blush: ) and all was well until the backup synched configs to the master and then it crapped out again.

When you can’t start the Ignition service we need to see the wrapper.log file located in c:\program files\inductive automation\ignition\logs. There will be an error relating to why it can’t start up. Typically, the memory is to high for a 32 bit installation or the path to Java is incorrect.

Turns out my problem may not be related to his… IIS had been enabled and was binding to the ports I was using for Ignition. Not sure who did it, but the event log will tell me!