PDF Viewer: Cannot access custom property

I have a pdf viewer that I created a custom property on called isZoomed. I’m changing the pdf view based on this custom property. For testing, i’m using a button to toggle the custom property. It works perfect in designer preview mode, but it does not work in the client and I get this error.

Traceback (most recent call last):

  File "<event:actionPerformed>", line 2, in <module>

AttributeError: 'com.inductiveautomation.factorypmi.plugins.reporti' object has no attribute 'isZoomed'

Button Script

pdf = event.source.parent.getComponent('PDF Viewer')
if pdf.isZoomed:
	pdf.isZoomed = 0
	pdf.isZoomed = 1

I saved the designer and closed it, then restarted the designer. The custom property disappeared upon restart. I recreated the custom property and published and the java error pops up but there isn’t a window with a message, just the Zulu logo. The gateway logs shows these two messages over and over since yesterday.

You need to restart your gateway (and get it contact with support). Something’s locked Ignition’s internal DB, which is preventing everything else in the system from accessing it and retrieving data.

1 Like

I stopped the gateway then started it back up. The errors went away, but I still cannot place a custom property on the pdf viewer. I tried deleting it and recreating it but didn’t help. Then I tried creating an invisible label to host the custom property. Doing that, everything works as it should. Weird! I’m waiting to hear back from support. This is just an FYI. Thanks.