Perspective apps failing at "Connecting" using External IP

About two weeks ago, my apps that have been accessible externally (for several years) started failing to load.
They just stop at "Connecting..."

If I access them internally, using either of the internal addresses, they load correctly.

I unaware of any firewall or Ignition changes in the months preceding this turn-of-events, but have since verified my firewall rules and updated Ignition to the latest version (8.1.37 from 8.1.30)

(Does Not Work) http://External_IP:8088/data/perspective/client/NightWatch

(Does Work) http://Process_IP:8088/data/perspective/client/NightWatch

(Does Work) http://Business_IP:8088/data/perspective/client/NightWatch

The External_IP:8088 gets passed from outer firewall to inner Business firewall, which allows access to Ignition server. This has worked ever since I set it up several years ago. On the off-chance something got changed, I decided to re-path it via inner Process firewall and get to the Ignition server via its other ethernet card. This did not correct my issue. The apps still get stuck at connecting.

I get these Websocket messages in the event log, which points me more toward a firewall issue, but as far as I can tell, nothing got changed on the firewall in the past month:

I tried turning off Auto Detect and setting my public IP and port, but that did not help - it just caused my internal IP connections to fail in the same way, as it was redirecting them to External IP.

I have looked at some of the other websocket related posts, but nothing seems to point me in the right direction.
Doing a comparison between a page load using the External IP and one of the internal IPs using Edge developer tools shows that it seems to stop right before receiving the application package.
This one fails - External:

This one succeeds - Internal:

Really starting to grasp at straws and probably doing more harm than good with all my tinkering. I hope someone out there can give me a fresh Perspective (pun intended :wink: )

I did 'half' figure this out.
I ended up removing are re-creating all the firewall rules and most of my issues went away.
There are still one or two pages that do not load consistently...on a sunny day, they will connect properly.
This does appear to be a firewall issue, just not sure how to proceed further without flashing it back to factory and starting anew.