Perspective Authentication issues

I’ve got a perspective application that currently using 8.0.13 RC1 and I’m having a bit of an issue with the Identity provider.

This is a gateway that has a couple of different User Sources configured, and a couple of different Identity Providers configured.

For this specific project I have a User Source called ICS_UserSource which is a database user source, and an Identity Provider called ICS.

I can properly authenticate users that are in the ICS_UserSource by clicking on the “Test Login” for the ICS Identity Provider, so I assume all that is working.

The goal is to use badges so when I use the test login I’m presented with the badge login page and then I can authenticate.

In the project properties I’ve set the Identity Provider to “ICS” and the User Source to “ICS_UserSource”.

image

I realize that the User Source portion isn’t applicable to a Perspective Session… It’s just habit to put it in there.

Now… the problem comes when I try and login from the perspective session. It appears that the perspective session is authenticating to the default Identity Provider

I have another project that was created with 8.0.10 and on the gateway when we upgraded the gateway and it isn’t having any issues. One thing I didn’t notice though is that in the project that is working the session.props.auth.idp is set for the Identity Provider specified, however in the project created in 8.0.13 the session.props.auth.idp is set for default.

If I change this project to the same setup as a project that is working, I get the same result. Authenticating against the default user source.

Any ideas?

So as a test I created a brand new project and set it up the same as the problem project and the new project is working.

Another update… I created yet another test using the “Perspective Web Nav” template and got the same issue. So it appears that maybe there is something bad in that template that is causing this? I also tested the “Perspective Menu Nav” and had the same issue. Starting a blank perspective app however didn’t cause this.

Is there an Identity Provider setting in Project Properties -> Perspective, as well? Midway through the 8.0 lifecycle we pulled the setting out from Perspective to general project properties, but left the old one in place to make sure nothing broke. The template project was probably initially created on an older version.

Yes there is. Set to default.

I didn’t even think to check there because of the changes.

Ya’ll might want to update the templates for the newer version… this took hours from my life :smiley:

Thanks for the help.

1 Like

Thanks for posting this - it was about to take hours out of my life too…