Perspective Multistate Button Not Functioning

Hello,

I have been having an issue with a multistate button in my perspective session. I have bound the controlValue and indicatorValue to the Mode property of my UDT params (and enabled bidirectionality).

I dropped 4 instances of UDTs into a carousel on another view (using one view as a template for another).

When I test functionality in my Perspective Workstation, I can click the button and it will change momentarily before reverting back to the default value (0). This happens for all 4 views that I have.

I have tried everything I can think of regarding property bindings, but haven’t had any luck.

Can anyone offer any insight?

Cheers!

On which one ? controlValue or indicatorValue ?

What kind of tags are they, and what’s their data type ? What data type are you trying to write into them ?

Presently, bidirectionality is enabled on both. They are all values in Perspective?
image
image

Neither an array nor an object.

Don’t make indicatorValue bidirectional.

Are they both bound to the same tag ?

1 Like

Unfortunately, I tried that and my issue still persists.
Yes, they are bound to the same property of my UDT.

I just tried, in 8.1.18, and it works fine.

Can you show us in more details how you’re trying to do it ?

Don’t think this is going to solve the issue, but if I’m not actually using a separate control and indicator value and only have one tag, I usually bind indicator value to control value and only have one connection back to the tag.

But yeah, at this point I think there is something odd in either the tag configuration(make sure you can write a value to that tag) or in your bindings that are throwing it off. Some additional info there may help in debugging.

I am able to write a value to the tag and it updates in my Perspective session just fine.

Here are some screen captures.

Well, you’re not binding to a tag, but to a view parameter…

Yes. This view acts a template for my other view in Perspective, so that I was able to drop Sensor instances directly into the Carousel. Those 4 views in the Carousel are all directly bound to their respective Sensors.

Is this incorrect? It was the only solution I found searching through the forum as there isn’t a designated Template option in Perspective as there is in Vision.

Check your view parameter type. Make sure that the parameter is set to bi directional and any bindings at the carousel are bi directional as well.

2 Likes

I believe that did it after a couple mistakes. :sweat_smile:

Thank you!

1 Like

No worries. Perspective sometimes has a few additional layers to unpeel when debugging haha.

Haha. You can say that again.
I didn’t even know there were more options for PARAMS until I right-clicked. :sweat_smile: