Perspective: Pasting in View Params via JSON not binding when passed in


If you have a View with Params (1) and you want to copy these into another View without Params (2) and you follow below, the params bind fine within the View itself to components, and changing the new param values updates the components, however if you embed the View onto another View and try to set the params from there, they’re not passed into the View, and the components use whatever the default Param values are.


  1. Create two Views, one with params defined (1), the other without (2). Put a component on both pages and bind them to the param value (the View without params will error for now).
  2. Shift+right click on each View → Copy JSON and paste both Views’ JSON code into separate notepad documents
  3. Copy the JSON contents of the Params section from (1) and paste them into (2).
    e.g. copy this from (1):
    and use to replace this in (2):
  4. Copy (2)'s updated JSON with new params and Shift+Right Click → Paste JSON back into (2) View. The component binding should now be OK.
  5. Embed both (1) and (2) onto another View and pass the param a value, different to the View’s default. (1) will work, while (2) will remain at its default value, despite having identical JSON code.

See attached Views.8.0.2 Template JSON Paste (3.9 KB)

Your replication steps are properly causing the parameters to not function correctly. In step 3, when the params are copy/pasted, you must also copy/paste the propConfig for that parameter for the view to understand that the parameter is in the input direction. After looking at the attached zip project, this appears to be the case.

To avoid having to copy/paste both parts of the JSON to a new view, which would be easy to mess up, it’s probably easier to first create params in your second view with no values, then just do a normal right-click copy on the first view’s parameters and paste them into the second view using the property editor.

1 Like

Ahh, whoops, that would definitely explain it. I’ve removed [BUG] from the title. Cheers!

1 Like