Perspective picture not updating?

We're using a picture on our mimic to show a map of the local area. We've got a view setup where a parameter is fed in from the URL, and this should then update the picture to show a different image. I've set up a binding on the image URL to check this parameter.

For some reason this works great when simulated in the Designer, but when I open it as a page everything else, tags, title etc., do update but this image refuses to change. Anyone come across this?

We're using version 8.1.16


I ran into this problem once. Try another browser to rule out caching issues first.

1 Like

You can add "?" followed by something that changes. this should bypass browser cache... i think

1 Like

Seems using other browsers the issue still occurs. I've tried Firefox and chrome.

I also tried to add ?1 and ?2 etc. to the end of the relevant images. This didn't seem to have any effect.

I'm wondering if there's a way to use custom methods or something like that to force the page to update it.
Temporarily I've given each map its own page. But that won't be as viable in long term as we intend to add many more sites to this system.

I would say, make sure the url changed. maybe binding a label to the picture url?

how me how you change the image