Perspective Table Column Naming

Using 8.0.16. When I drag a table into a view, I give each column a name that is displayed on the header. After I save the project and launch a session, the columns get rearranged and put in alphabetical order. After looking at the users manual and searching the web, I can find no information on this feature. My workaround was to rename the columns so the showed up in the correct order. Is there an way to turn this sorting feature off?

I’m not able to replicate this in 8.0.16. Could you provide screenshots of the relevant properties with their values visible? Like this:
Screen Shot 2020-12-04 at 7.11.22AM Screen Shot 2020-12-04 at 7.11.35AM

And then also a screenshot of the Table in an active session, like this:
Screen Shot 2020-12-04 at 7.11.51AM

Is it possible that you’re defining the title of the header without properly defining which data column should be in use for that column? It’s imperative that column.field match that of the desired column from your data source which should be displayed.

I did not go down to the columns property. What I did was to take the columns from the sample table and modified them to meet my needs. The columns I used were defined under the ‘data’ property. I ca show you the screen shots, but all is well now. Thank You.

The data in the Table is not configured to specify column order - it will default to the order of the columns within the provided data, which happens to be alphabetical order (city, country, population). To control the order of the columns, you need to configure the columns individually.

I am rather confused. I scrolled down the the columns property. I modified everything I could find that refers to the column header. Using the sample table data, where are the columns ‘city’, ‘country’, and ‘population’ defined? I am assuming these fields are what is referred to as the header.

The order of the column configuration objects in table.props.columns is what determines the order in which the columns are displayed. So, if you wanted the city column to be first, the first object in table.props.columns needs to haves its field property set to ‘city’, then repeat this for each column in your desired order. if you want to change the title of the column, change the header[title] property in the column object.

table

I know I am missing something very basic…

the ‘field’ value in the column object needs to be the same as one of the names of the columns in your underlying data set. since that example data set doesn’t have a column with the name ‘Dock Door Number’ the table doesn’t know which column in your dataset to pair with the column object with field=‘Dock Door Number’. trying setting the field property in each column object to ‘city’, ‘population’, and ‘country’

Ah, Ha! There are just to many items called ‘column’.
Thank You Again

1 Like