Perspective View opening as black screen in Designer


When I want to open a perspective view in the designer. It’s not working like the screenshot below.
Do you know what it causes this issue ? So I can modifiy any of my views.

I’ve already reboot the gateway. It still not work.


What version of Ignition is this? What OS are you running the designer on? Are there any errors in the designer’s logs/console when this happens?

Ignition 8.16
Windows server 2016
It seems the error is “Websocket disconnected from session.”

Have you closed and re-launched the Designer?

Yes I do and I’ve reboot the gateway.

When I open a view the designer is freezing and I have the error below.
I can’t even see my session variables.

When I open the view named “info”, I have gateway messages below:

Client sessions works in web browsers.

1 Like

maybe You have there some scripts on StartUp page?

I have script in session events. Same problem when I delete it.

did You do backup before making changes? if yes, just restore this working backup…

Everything you’ve posted so far indicates a problem initializing JxBrowser, the library that hosts an embedded Chromium window in the designer. Do you have access to any other computers to test the designer on? Are you launching the designer inside an RDP session, or directly on the host? Is the server virtualized?

Yes our server is virtualized.
I’ve launched the designer directly on my server (with RDP) and on my PC. Same problem.

Hi… I see no resolution on this, and I am experiencing this same issue with version 8.0.16. Can someone confirm upgrading to 8.1.4 might solve this issue?

It certainly might; we bumped the version of the embedded browser library significantly in 8.1.0, which resolved a lot of compatibility problems.

OK, thanks, I have this schedule to upgrade tomorrow morning. Let’s hope.

Thanks for the quick reply.

OK, so I was just preparing for my upgrade… we’re using the MES module from SepaSoft… do I understand correctly that they do not have a compatible module for 8.1? Is that going to have me stuck on this version?

I’m not an expert on Sepasoft’s modules, but it looks like they support 8.1 fine:

OK, I did my upgrade, all went well, except I have one system that is hanging on the “Locking Resource Directory…” dialog. I’ve cleared the .ignition cache folder and tried to re-run from the client launcher, but still hanging. Other client launchers are running fine. I’ve opened another support ticket (13530), so I guess we can close this one if you want unless you have an idea here.

Thanks for the feedback / help.