Perspective XYChart: no series properly configured

I’m using an XYChart, the properties of which I populate dynamically. I have just one dataSource in the dataSources prop which I populate with a query binding; the yAxes array prop is also populated with a query binding; the series prop is populated applying a script transform to my dataSource. The weird behavior I’m experiencing is that as soon as the dataSource data gets updated, my XYChart shows the No series properly configured warning. However if I just change the chart title, e.g. by clicking a button in the view that sets the chart title, all my pens are plotted correctly. I tried to work around the problem with a Property Change Script on the dataSource, where I assign the series prop after a delay with the assignLater function from @pturmel module, but with no success - that’s because I thought that dataSource and series props cannot gets populated almost at the same time.
Any suggestion?

Thanks in advance, regards

My ignition version: 8.1.16 (b2022040511)

Possibly an expression structure binding to supply both series and dataSource at the same time?

I’m experiencing the same issue.

I’ve tried populating the datasource and series props in various orders. From separate bindings as well as from the same script transform. I’ve tried pushing the settings to the props, as well as having bindings on the props pull in the settings.

Sometimes it works.
Sometimes I get the “no series properly configured” error.
Sometimes it half works (the chart will be mostly right, just missing colors, etc.

Any ideas would be appreciated.



I'm getting the same behavior.

My binding order is:

  1. Named query in a table that has a dataset as a result.
  2. XY Chart getting data from that table to the example datasource.
  3. Series property being fed from the example datasource.

It works well until I change the dates to where there isn't any data. With no data it's blank, which I don't mind. When I switch to dates that have data, it displays 'No series properly configured'

Hi, I am getting the same problem now. Were you able to figure it out?

Yes and no.

There is a known bug for XY charts (IGN-2447)

Try to always have xAxes, yAxes and series properties as stable as possible. Then apply bindings directly on the nested property your trying to animate/change.

i have this problem as well, any solution yet ?

I think those bugs are still in the latest version. I haven't checked.

Workaround is the same as described:

What is the problem you are having?

No series properly configured..

i did what you said...


Did it work? Hope so.

You're welcome

yes it work