PLC protocol change over 4RF ethernet radio

I am changing over from MDS radios via KEP to 4RF IP radios. I’ve noticed recently that the protocol on the gateway changes and searches on its own to go from EIP (which I need) to PCCC (which causes a comm loss). I am using AB Micrologix 1100/1400 PLCs in the field. I have my timeout settings for 1 min which is more than enough. I was curious if anyone has had this issue before and what could be done to solve it.


Disclaimer: I am not a PLC guy, at all.
But I think the discussion here might help you out?

Seems to still be an issue even in version 7.9.6.

Try setting a connection path of 1,0.

I’d like to get a setting on the driver that lets you choose between “auto” (the current behavior) and explicitly choosing a protocol but it may not happen until Ignition 8.

I dealt with this by using firewall filter (ubuntu 14.04)…

# iptables -t filter -I OUTPUT 1 -m tcp -p tcp --dport 2222 -j REJECT
# iptables -L -n
Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
REJECT     tcp  --              tcp dpt:2222 reject-with icmp-port-unreachable

To keep this permanently we install a package…

apt-get install iptables-persistent
1 Like