Poll: Naming Convention for Custom Properties

How Should Custom Properties Be Named
[poll]

  • Upper camel case? Example: MyCustomProperty
  • Lower camel case? Example: myCustomProperty
  • Upper case? Example: MYCUSTOMPROPERTY
  • Lower case? Example: mycustomproperty
    [/poll]
    I’m working on a Ignition Project Development Style Guide.

I’d like to know how people currently prefer naming Custom Properties on components.

Based on poll results and user input, lower camel case has been chosen for the style guide.

Thanks for your votes!

I know I’m late to the party here but honestly I think it should be both upper and lower camel case.

If you are talking about a singular property use lower camel: startDate, orderQuantity, postageRequired, shippingMethod, etc.

If you are say passing a complex UDT into a template use upper camel so that at a glance you can tell “this property/parameter is different/has more depth to it”