[Possible Bug?] Local OPC-UA reference now case sensitive and has to be "localHost" not "localhost"

I have upgraded a 7.9.10 project to 8.0.0 (b2019040718). All tags using local Ignition OPC-UA weren’t working. Eventually, I worked out that our reference to OPC Server “localhost” had to be changed to “localHost” on all tags. Is this case sensitivity deliberate or simply over looked? It’s an easy bulk fix with export/import, but I wanted to check your intention.

Can you clarify: was the name of your OPC UA connection “localhost”, or are you talking about the hostname it was configured to connect to?

My apologies. It looks like the connection name is localHost. I should have checked that. I can’t tell if we had it as localHost before the upgrade or not. But I know that all our tags were working with “localhost” as I’ve had to change them all to localHost for it to work. Once I’m back in the office, I can spin up a 7.9.10 with the old back-up and clarify that.

I think this inadvertently became case-sensitive in 8.0. I’m surprised it wasn’t already.

Have you considered changing the connection name to all lower case instead of changing all the tags?

@Kevin.Herron sorry for not getting back earlier. I can confirm that in 7.9.10 (prior to upgrade) our connection was named “localHost” but all our references were “localhost” and they worked in 7.9.10. So you’re absolutely right, 8 is now case-sensitive. A simple fix for me, but potential pitfall for others during an upgrade?

Thank you. I guess I was more interested in the cause rather than the solution as we have a few 7.9’s to upgrade. But I know what it is now. :slight_smile: