Power Chart -- Incorrect interpolation on realtime mode, but not historical

We have some accumulators and daily totals that roll over at midnight and display the previous day’s values. As such, when charting them, we want the graphs to have stepped values. To do so, we’re using curveStepAfter for the interpolation, which works perfectly for the historical mode on the Power Chart. However, when the mode is changed to realtime, the interpolation stops working and the chart becomes useless.

Is there some setting has been overlooked, is this a bug, or is this just expected behavior for realtime vs. historical? I’ve tried playing with all of the interpolation and aggregate modes, as well as breakLine, but haven’t been able to get it working.

Here’s the chart and properties for the erroneous realtime:

And here’s the desired graph from historical mode:

Bump. Still having the same issue.

I think another way to phrase this problem is that realtime charting isn’t respecting the aggregateMode of the pen.

Edit: The problem may actually lie at the tag level–the charting might be working perfectly fine. Will update.

After getting ahold of support, we determined that, although the data is good (1 value per day, nothing funky going on), there were in fact some tag history settings that were messing up the Power Chart–setting the Deadband Style on these tags from Auto (which was defaulting to analog for these tags, since they have the type Double) to Discrete, in addition to changing the querymode column in the sqlth_te table to 0 solved the issue.

Now to make these changes across many, many tags…

1 Like