Power Table Data Property Binding Will Not Accept Changes


I have a Power Table and I have bound the Data Property to a SQL Query. The table was working fine and reading properly from the database, but then I wanted to change the SQL script. When I went to make a change, I ran into this problem:

Clicking the ‘OK’ button to confirm current settings or to accept changes to settings in the Property Binding window for the Data Property of a Power Table yields the following Console Error output:
Exception in thread “AWT-EventQueue-0” java.lang.NullPointerException

I can submit a longer log if necessary. I have gone as far as restarting my computer and going directly back to this table, but the problem persists (the database is on my local machine). If I create a new Power Table and copy the SQL query to it there is no error. If I then modify the query in that new table there is no error.

I could of course create a new table and re-configure it to match the same style, but I am worried that this error will crop up again in the future.

I am currently using:
Version License
Ignition Platform 7.9.7 Trial
Reporting Module 4.9.7 Trial
Alarm Notification Module 4.9.7 Trial
SFC Module 3.9.7 Trial
Enterprise Administration Module 2.9.7 Trial
DNP3 Driver Module 2.9.7 Trial
OPC-UA Module 4.9.7 Trial
Vision Module 9.9.7 Trial
SQL Bridge Module 8.9.7 Trial
OpcCom Module 4.9.7 Trial
Symbol Factory Module 5.9.7 Trial
Mobile Module 4.9.7 Trial

Java Version: Oracle Corporation 1.8.0_171
JVM Memory (used/max MB): 403.5 / 910.5

Known bug. Reported recently here on the forum. Start here.

Thank you for the response, and I apologize for submitting a known issue. I tried searching but I didn’t come up with anything.

I have taken a look at the various other threads and it seems like the solution is: wait for version 7.9.8 and until then - get your SQL query right the first time.

Or stay on 7.9.5 or 7.9.6 for a little while.