Printing missing some text

I am using 7.9.12 and a script to print the parent component. I am getting a result in which most all of the text is missing. The tag values in the result are there, but none of the labels.

My print script:
job = system.print.createPrintJob(event.source.parent)
#job.orientation = system.print.LANDSCAPE
#job.setMargins(0.5)
job.print()

(I commented out two lines above that create an error when I sent it to the antique printer).

I thought it might be a missing font since “Dialog” was used for most of that text that is missing and “Dialog” does not appear in the Windows list of installed fonts. I switched the (underlying template) of the fields to Arial and that did not help.

I thought maybe it has something to do with the fact that it is a template repeater displaying those lists, but even the (now arial) font in the title bar is blank.

See the screenshots from the print result (pdf or real printer looks the same) and a screenshot from the client (normal) appearance.

1 Like

A little bit of reading material about fonts: ( add the h to change ttps to htt… the first message does not appear if I skip it )
ttps://forum.inductiveautomation.com/t/font-issue-in-vision-client/27091
ttps://forum.inductiveautomation.com/t/ignition-8-0-2-font-is-different-to-7-9-6/26547
Also, I have been reminded that you can start at:
https://support.inductiveautomation.com and visit Policies ( Policy ) if time is short.
Please let us know when/if you get a resolution. Inquiring minds want to know…

were you able to figure out the cause of this problem?

Not yet.

So I spoke with support and they informed me that this is a bug caused by an embedded java version when launching a project/designer from the client launcher. On version 7.9.12 of Ignition there is a check box which you can disable this option or if working with an earlier version you may launch the JPL of the project.

1 Like

Thanks for that. When I get a chance, I will log into that machine and look for that option.

Thanks, always good to know about these Java changes.

This did work to fix the problem. I went to the browser and used the Launch Project button to download the jnlp file for the project. Windows and Chrome tried several times to prevent me from saving that link, but once I started the project from it, all the print features work as expected. I then needed to set that link up for Windows 10 to use at startup (why does Windows move everything every time they release a new version?) So I had to google how to find the Windows 10 startup folder in order to make sure I could reboot the machine and get the client to launch…that all worked too.

Thanks for the tips!

1 Like

So in order to fix this, you have to disable a key feature of 7.9.12, which is using embedded java?

Is there any other way?

In my case, checking off the “Use bundled JRE” flag didn’t help, I have to use the Java webstart (jnlp) to get text to print.

Don’t know what the difference is…

We’re working on a solution to this. It’s actually a bug in OpenJDK, but it might be possible to circumvent using some local code.

1 Like

Try making the Text HTML…seems to work for me.