Problem after updating to 7.6

I just updated our server to 7.6 from 7.4 and am having OPC problems. My Controllogix processors are showing connected, but I am getting a general error in the OPC Server. If I go to Status, OPC Connections, the IgnitionOPCUA is showing faulted with the error
“Could not open secure channel to opc.tcp://
Any help would be appreciated. Did a restore of the app and resulted in the same error. Also restarted the server with same result.

Is that the correct IP address for the server? Can you export the logs from the Console > Logs tab and upload them here or email them to support?

Address is correct, I’ll see what I can do about the logs.

OK, when I try to export the logs, I get an “Internal Error”.
I did a screen capture and have attached that will hopefully help.

Ah, well, it looks like you may just need to regenerate your certificates…

In the Configure section, on the left under OPC-UA Server > Certificates, go to each of the three certs there and click regenerate->yes. Restart the gateway, then see if your UA connection is valid again.

If that doesn’t work we’ll have to shut the gateway down, delete the opcua-module.keystore and opcua-module.keystore.bak files from the ${installdir}/data/opc directory, then start the gateway again.

Regenerating did the trick! Didn’t recall having to do that on the older versions, one to remember now. Thanks as usual for the prompt response!