Problem Connecting to S7-1500 PLC

I am new to Ignition and I’m trying to connect an S7-1500 PLC to Ignition via Ethernet. The PLC is in run mode and I entered the parameters as defined in the Connecting to S7 Devices Tutorial, but Ignition will not connect. Is there anything on the PLC side that I need to configure? Or does there have to be a functional program running on the PLC?


Shall I ask a stupid question? Are these PLC and Ignition servers are on same network right? Are you able to ping its IP address from Ignition server?

Ha, that’s a great question. I just realized my subnet mask was wrong. Now it works!


Also, you need to do this:

Thanks for the support. I’ve got the PLC connected and configured per the link you sent, but I’m having trouble retrieving data. I’m trying to retrieve an integer at offset 4 at DB10.DBW4 and my OPC item path is [S71500]DB10,I2 but my value is null and has bad quality. Any advice?

If you right click on the tag Input2 and choose tag diagnostics, what is it say?
In Simatic integer is 16bit, in Ignition integer is 32 bit. So in Ignition you must choose Short as Data Type.
Also if you want negative numbers you choose I4 (-32767 to 32767), if you want only positive numbers you choose W4 (65536)…

The tag diagnostics show “Bad Quality.” I get the same results when I try to read in the booleans I have mapped to DB11. Would I get “Bad Quality” if a sensor weren’t connected correctly. I made the change to a short but that didn’t fix it.


So just to confirm the gateway shows the PLC as connected and the Datablock your trying to access has optimized access disabled?

Along with the get / push option enabled?

Going by your tag reference you have called the PLC ‘S71500’ in the devices on the gateway ?

Hi Craig. Yes, the gateway shows the PLC as connected, the optimized access is disabled and the get/push option is enabled. Correct, I named the PLC ‘S71500’.

I re-compiled the program in a different instance of S7 and it’s working now. I don’t know what the issue was but it’s resolved. Thanks for the input.