Problem launching Ignition from docker

Hello everyone,
I’m trying to run an ignition instance from docker, but I set the default port 8088 and I have another instance of ignition running in the local OS.
I tried to change the port but I can’t load the gateway. Any suggestion?

Leave the port as 8088 inside the container, but map a different port on your host OS.
When you create the container (whether using the official images for 8.1 or Kevin Collin’s community images for 7.9/8.0) you can specify ports on the docker run command, e.g. docker run -p 9088:8088 --name test inductiveautomation/ignition:nightly - 9088 is the host port, 8088 is the port inside the container.

Thanks, Paul, I’ll give a try!

Paul, for some reasons I don’t have the Gateway Control Utility installed in my OS.
Is there any other way to change the port?

If you’re using Ignition 8 you should be looking for the command line util instead: https://docs.inductiveautomation.com/display/DOC80/Gateway+Command-line+Utility

Hi guys,
I changed the local OS http port as follow:
C:\Program Files\Inductive Automation\Ignition>gwcmd -k 80
HTTP port changed. The Gateway must be restarted for this change to take effect.

Docker settings:
Restarted the gateway (I had to do it under windows/services)

And tried to access the localhost but neither the local OS and the docker works.

Adding gateway.publicAddress.autoDetect=false to gateway.xml

Adding gateway.publicAddress.address=0.0.0.0 to gateway.xml

Adding gateway.publicAddress.httpPort=8088 to gateway.xml

Adding gateway.publicAddress.httpsPort=8043 to gateway.xml

I’m confused. The last messages logged make it seem like you’re using the official Ignition docker image, which is Linux only, but you’re running a gwcmd on a Windows system? It seems like you might be interacting with a different gateway than you expect.

Besides that, I suspect that one issue might be the 0.0.0.0 gateway address - there’s currently an issue in the official docker image, where if you don’t specify a valid HTTP address with the -a flag the HTTP address will be set to 0.0.0.0 explicitly, instead of auto-detecting. If you can reach the gateway web interface, you can re-enable the auto-detect setting - or you could manually do so inside the container by editing gateway.xml in /usr/local/bin/ignition/data.