Problem OPC path and tags on 8.1

Hello, I’m trying to communicate with my OPC UA server with Siemens S7-1200. Before, on 8.0, I connected my tags like that :

With the path “ns=5;i=40” for example. And it worked very well.
But now, when I import my tag from “Browse Device” on designer or “OPC Quick Client” on Gateway, the OPC path change (for the same OPC connection) :

With path “nsu=http://Stations;i=40”
I can read the value of my tag with “OPC Quick Client” but I can’t subscribe and I can’t use it on the designer. I have “Error_Configuration” image

And if I try to change the path to “ns=5;i=40” sometimes it’s working sometimes I’ve the same issue.
I really don’t understand why. On the 8.0 it worked very good. Someone know where is the problem ?

This explicit namespace URI syntax should work the same as long as the server keeps its namespace table up to date.

You’re probably experiencing some other problem.

Change the log levels for the loggers you find searching OpcUaSubscriptionModel and OpcUaSubscriptionSynchronizer to TRACE level and then edit/save the connection. This should log the StatusCode received from the server when the monitored items fail to get created. My guess would be you already have too many items or subscriptions - the S7-1200 OPC UA server is very limited.