Problem wih Mobile Module


We installed Ignition 7.2 Beta for trying out Mobile Module. We developed small screens for better viewing on the mobile. However, when we try to access the application using IPhone 3.0, we are getting and not able to view the Project once we login through the login page.

Please help us to resolve this issue.

Thank you

Can you send us your wrapper.log file from around the time when this happened?

This is the Wrapper.log when I tried to Open.
MobileModuleProblem.txt (3.19 KB)

Ok we’ve made a change to the mobile module to help us debug this. After the next release, add this to the “JVM Options” setting for the mobile module:

Then replicate this issue, and we’ll take it from there. You’ll need version 6479 or later before you do this.

Dear Carl,

We installed Ignition 7.2.0 (b6498) on Ubuntu. We also set -Dmobile.debug=true in JVM Options.

When we try to open in mobile, we are getting Connection Reset Error. The Wrapper.log file during that period has been attached.

Please help us as soon as possible.
Wrapper.log (3.73 KB)

ok with that flag set you should be seeing log files being put into your
folder. Send those to us.

Dear Carl,

There is no such directory available in the Contexts. We are using Ubuntu 8.0 Version. Is there any problem with OS or Installation ?

We haven’t tested in Ubuntu 8. I’ll give it a try tomorrow on a VM.

Dear Carl,

Still we are facing same problem. Even with the Windows version also.

We are struck in this challenge. Can you please help us to overcome this.

Thank you

Just to update anyone else who is trying to run the Mobile module in Linux, we’re having some issues with how the virtual clients attach to the windowing system.

The easiest workaround is to basically log in and start Ignition by hand instead of having it start up with the Computer. We’re working on something better, stay tuned.

I was using the mobile module with out any problems on Ignition 7.2.2. It recently stopped working. The only change I’ve made to the server is installing Apache. I’m using SuSE Enterpise Server 11, with a Gnome GUI.

I tried updating to 7.2.4, but I’m seeing the same thing, I just get Connection Reset when I go to run my mobile app.

I used use the JVM Option to see the logs.


ClientVM-ba8f446f-97bc-28ca-8407-fa473e248342-out.log (124 Bytes)ClientVM-ba8f446f-97bc-28ca-8407-fa473e248342-err.log (1.13 KB)

I tried a fresh install of Linux (SuSE Enterpise 11 with Gnome) and the latest Ignition ( I tried to be more cautious about the repositories that I was using and the order that I installed things. I am stopping and starting Ignition manually. I’m seeing a different error than I was before when I try to start my project with the mobile module.

ClientVM-2d5f56d7-734c-23b9-07e4-329dd2437ac2-err.log (1.31 KB)ClientVM-2d5f56d7-734c-23b9-07e4-329dd2437ac2-out.log (117 Bytes)

I think it is safe to say that a person needs to have the latest version of Java installed and to make sure that it is from Sun. OpenJDK Runtime 1_6_0 or an older version of Sun’s Java like 1_6_0_u7 does not work with the mobile module.