Problem with a storeProcedure


I exec a storeprocedure and try to get the value of the store but i can`t.

i checked the link system.db.createSProcCall - Ignition User Manual 8.1 - Ignition Documentation

but i only get None with the funtion “call.getResultSet()”

so i think the problem is the SP, i tried with return, with select also output int the store.

In all the situations if i exec the SP directly in SQL always give me a value,

what i made wrong?

Please share your stored procedure and the scripts you tried. We aren’t mind readers. /:


I think it’s in line 15 of the SP, that’s my hunch. That feels wrong to me


Except for Nick.

Eric, did you find a problem on line 15?


imagine if Nick was right xd

1 Like

Sorry guys, but i really need to give to solution to the problem, so i made a select after exec the SP, but the SP its something like:


and tried to get the result with :

results = call.getResultSet()
table = event.source.parent.getComponent(table) = results

The final line in your SP is syntactically incorrect. Try:

Select @resultado AS out