Problem with Data Types instances

My first instance is ok :: {uf} is solve
The second is bad, the third and all other.
if I only instance it works.
you can see on the image.


I solved my problem…
I have deleted and recreated my SqlTagProvider and redone my SqlTags type and now it works.
the problem appeared when I move and rename my instances.
Is there a method to purge SQLTags delete the Provider ?
Have good day.

finally my problem reappears when I modify the parameters of DataType.
Thank you for your help.


I think the easiest way to troubleshoot this would be for you to upload your gateway backup to ticket number 7586. That way, I can trace through the parameter replacing, and see why it’s not being applied. If this isn’t possible, let me know and I’ll see what else we can do.

Also, what version are you currently using?


I just posted my backup with error.
I am in 7.5.0, but I also tried with version with the same problem.

Thanks, I was able to track it down fairly easily.

The problem had to do with the “scope” of parameter overrides. In your case, on the instance that don’t work, you’ve overridden some parameters of the nested types, but not all of them (and you shouldn’t need to). When it filled in the properties, it didn’t have the value for the non overridden parameter, so they were left as they were.

I’ve committed the fix and it will be available in the next 7.5.1 beta, which should get put up today I think.


Great, you do a good job :thumb_right: