Problem with DSN connection

I am trying to setup a DSN connection in factorySQL. I got it working a few months ago, but now it does not seem to work. When I select the DB connection and try to “view table data” I get an error Cannot execute query. An error occured while loading the data connection, and data caching is not enabled.

Not sure what is going on, I have data caching enabled. I also tried entering a query that I know works, and still had no luck.

EDIT: I tried this in 4.1.5 and it works ok… AHHH! Why wont it work in 4.2.4?

Have you tried running a group using that connection yet? Does the problem only occur when viewing table data?

If you go to Help->Log Viewer, are there any errors that may provide more information as to what error is occurring?

And finally, which ODBC/database driver are you using?


In log viewer… The category is “Service Bridge” The message is “Error in service bridge” and the details are what I posted before.

If I try to start the group it says data connection not avaiable. If I continue past this it will start, but generate an error “The necessary data connection is not avaiable and the requested operation cannot be cached.”

I tried to start it in a old copy of 4.1.5 I have and it will actually list all the fields in the tbl and attempt to start properly.

I am using a Old database system called Progress that houses our MFG/ERP system. They distribute a custom ODBC driver.

Ok, so did you (or we) make a custom database translator file (the xml file in the databases directory) for that driver? Or do you have a specific one selected?

Off the top of my head I don’t know of specific changes in the translator format from 4.1.5 to 4.2.x, but I’m thinking that’s what’s going on. If you have a custom translator or know which one its using, attach it here or email it to support AT inductiveautomation DOT com.


I was using SQL Server and it was working fine…

I tried all of the translators and get the same results…

Could you go to C:\Program Files\Inductive Automation\FactorySQL\database and send us (or attach here) the SQLServer.xml file?


Here are both from versions 4.1.5 and 4.2.4

I am not sure if the problem lies with this, as I get the same errors with other translators as well.

A diff between the two files doesn’t show any major changes.
Sql (1.91 KB)

My best guess is this happened with ver 4.2.0

[quote]Fixed - Many improvements to datacache system:
o Better threading, lots of data in cache no longer causes service to start slowly.
o Automatic periodic database checking, data loading (earlier versions only checked on certain events).
o New “quarantined” data facility to handle queries that error out on load.
o Improved system status screen, with facilities for deleting cached & quarantined data, as well as viewing errors.[/quote]

With the updates to the datacache system. However I do not know the code, so it is just a hunch.

Ok, those look fine. Try the following:

  1. Stop any groups that might be running against other connections (if there are any).

  2. Go to Settings->Log Settings. Enable “Debug” messages.

  3. Try to open the table viewer as before. You should get the same message about the connection not being available.

  4. Go back to the log viewer. You should now see a debug message (little bug icon) under DBSystem that will show the error occurring during connection. Post that here, and hopefully that will provide some more information.


Ok I finally got it… After getting into debug mode, it started showing me some more errors related to the DB driver, turns out that these were generated by some permission errors because factorySQL is running as a service. I re-configured the DB driver, and it seems to be working so far…

Hmm… I wonder why it was working when you went back to 4.1.5? At any rate, I’ll put a “enhancement request” in the system for a better error messages in cases like this.

Oh, and don’t forget to turn off debug messages, or else your log will be filled with generally useless stuff quickly.