Problem with OPC-UA connection

I have a strange issue with an OPC-UA connection. In the gateway in status is showing an OPC-UA connection that I cannot see in gateway config. It is marked as FAULTED and it shows the exception:

java.lang.Exception: Error creating OPC server “SIMATIC.S7-1500.OPC-UAServer:PLC_1” of type “com.inductiveautomation.OpcUaServerType”

  • at com.inductiveautomation.ignition.gateway.opc.OpcConnectionManagerImpl.newOpcConnection(*
  • at com.inductiveautomation.ignition.gateway.opc.OpcConnectionManagerImpl.registerConnectionType(*
  • at com.inductiveautomation.ignition.gateway.opcua.OpcUaModule.startup(OpcUaModule.kt:304)*
  • at com.inductiveautomation.ignition.gateway.opcua.OpcUaModuleHook.startup(OpcUaModuleHook.kt)*
  • at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl$LoadedModule.startup(*
  • at com.inductiveautomation.ignition.gateway.modules.ModuleManagerImpl.startup(*
  • at com.inductiveautomation.ignition.gateway.IgnitionGateway.startupInternal(*
  • at com.inductiveautomation.ignition.gateway.redundancy.RedundancyManagerImpl.startup(*
  • at com.inductiveautomation.ignition.gateway.IgnitionGateway.initRedundancy(*
  • at com.inductiveautomation.ignition.gateway.IgnitionGateway.lambda$initInternal$0(*
  • at com.inductiveautomation.ignition.common.execution.impl.BasicExecutionEngine$*
  • at java.base/java.util.concurrent.Executors$ Source)*
  • at java.base/ Source)*
  • at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ Source)*
  • at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)*
  • at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)*
  • at java.base/ Source)*
    Caused by: java.lang.IllegalStateException: context.persistenceInter…erSettings)
  •        ) must not be null*
  • at com.inductiveautomation.ignition.gateway.opcua.client.connection.OpcUaConnectionType.createNewOpcConnection(OpcUaConnectionType.kt:43)*
  • at com.inductiveautomation.ignition.gateway.opc.OpcConnectionManagerImpl.newOpcConnection(*
  • … 16 more*

8.0.17 (b2020111211)
Azul Systems, Inc. 11.0.7

It is very annoying because I have a table where I show all OPC-UA connections (despite they are FAULTED or CONNECTED) and this one is appearing there and no one know what it is. The table uses the script system.opc.getServers() to be filled.

Does someone know what can be the reason of this connection?

Was this server an upgrade from v7.9? That might be the old OPC-UA classname that doesn’t exist in v8+. You might want support to walk you through the internal DB corrections that will be needed.

Some field in the internal DB is null but I can't tell what's going on because the stack trace you posted is mangled.

As Phil suggested though it might require some poking around in the internal DB by support. The connection name is "SIMATIC.S7-1500.OPC-UAServer:PLC_1".

yes as you say I upgraded from 7.9 to 8, but it was long time ago and this connection appeared for first time some days ago.

I tried to find the connection in the internal Ignition db, I ran the following query, but this ‘phantom’ connection doesn’t exist:


I solved uninstalling Ignition and installing it again. I loaded a gateway backup and surprising the connection disappeared.