Project launch desktop icon

I am really confused on this issue and would like some help so I can make it easier for my customers to use our app, please.

I am not sure of the best way to do what is needed here. I have used a link similar to the following that I can email to the customer and they can click on it to launch the project. Sometimes it will automatically create a desktop icon with which they can launch it again in the future. Other times it doesn’t create the icon, and I can’t figure out why. I have experimented several times on more than one PC. I have tried deleting the .ignition folder in the C:\Users\MyLoginName folder and that doesn’t seem to have any effect.

Here is a link very similar to the one I send them. I have changed the server name and the app name, but the rest is identical. Quotes added to make the forum not consider it a link and mess it up.


Can someone please help me understand this? I need to send them something that always works and doesn’t require me to have to try to walk them through creating a desktop shortcut and pasting a link into it and naming it the project name. Our mail server won’t allow us to send a desktop icon, I believe because of the .jnlp inside the link, but I can send the link itself with no problem. Your help with this would be greatly appreciated.

Hi RRRancher,
You have two issues that I can see: (assuming you are using a Windows environment and Java 7 )
1.) Desktop Icon “sometimes” created - this is a Java setting that is related to each individual PC you are trying to launch the application on. You can change those settings from the Java control panel under the Advanced Tab -> Shortcut Creation setting.
2.) the jnlp link you are showing seems to be missing the port number (I could be wrong here if you have changed it to :443 - or whatever the default HTTPS port number is :slight_smile: )


Thanks for the reply. I will look at the Java control panel and experiment with the settings.

We are using SSL and have a certificate for our website. We changed the port number from the default for SSL. The link always works to open the app. It just doesn’t always create the desktop icon, and that is the main problem I am trying to rectify here. Hopefully your help will do the trick. I appreciate your time.

Tried setting the Shortcut Creation setting to Always Allow, but it would still not create a shortcut on some PC’s. They had shortcuts to other servers at one time, and those were deleted when we moved to another server. I have yet to get it to create a new icon on those PC’s now. Any more suggestions?

Once you delete a Java shortcut from the desktop downloading will not re install it. In order to restore it go to control panel, Java, General, Settings, Delete Files, Applications and Applets and Trace and Log Files, Ok. Download again from the gateway and it should restore the missing icon. Upgrading from Java 6 to 7 will also cause this problem.

1 Like

Thanks for the info, Mike. Unfortunately, it didn’t work. I even tried deleting all three things and also the .ignition folder in my user folder. I noticed in the Java control panel that it showed the location where temporary files are kept. So I went there and tried deleting the C:\Users\MyUserName\AppData\LocalLow\Sun\Java\Deployment\cache\6.0 subfolder first, and that is what did the trick. The next time I clicked the link, it created a new desktop shortcut.

This is a Windows 7 Home PC and I don’t believe it ever had Java 6 installed on it. I believe when I built it, Java 7 was already out. Hopefully this info will help others who may be experiencing this same problem. Thanks to all who helped figure it out.

Usually the way to get the link to re download is as Mike explained. This is referred to as clearing the Java cache. Why it didn’t work is strange. I’m curious if it works like clearing the Windows temp folder, it only removes things of a certain age. If this is the case then all of the Java cache isn’t removed.

Another alternative for you is to create a direct link. You can find the instructions in the link below. This will give you a static icon on the desktop that will not go away unless deleted.


Thanks for the reply, Greg. I had read the entire topic you linked and sent the link I created to my customers, as I explained in the first post of this topic. The problem was that it didn’t always create that permanent icon on the desktop. I have had no further problems since I fixed the ones I initially had by clearing the C:\Users\MyUserName\AppData\LocalLow\Sun\Java\Deployment\cache\6.0 subfolder, as described in my previous post. Perhaps it is the problem you described where the entire cache was not being cleared. If it occurs again, I will investigate more on this line, if time permits, and let you know if I find anything.

FYI, I just found your reply to this topic tonight. I have been subscribed to the topic since I created it but got no email indication that a new reply was added. Not sure why. Just wanted to let you know.

And the file path you listed to the temp files is the default location for the Java cache. You can also delete this from the Java console located in the control panel.

Greg, if you look at the post from Mike Steele and mine immediately after, I had already tried deleting the cache from the Java control panel, but it didn’t work. I really do believe there is some kind of cache in memory that has to expire, or something like that, so deleting from the Java control panel does not instantly work. I may be totally wrong, but all I have to go on is the experience, at this time. Like I said, if it happens again, I will try to test a bit more thoroughly, and will post here if I determine anything. Thanks again for your help with this.

No problem, let us know if you find anything else.