Project opening in designer but not as client?

Using Ignition 7.9.2. Using Java Version 8 Update 151 build 1.8.0_151-b12

I have multiple projects on this gateway, but only one is giving me this issue. I am able to open and edit the project inside my designer. But trying to launch a client, the Java popup opens up, but then nothing happens - no login screen, no project window etc. I also cannot run a Published or Staging view of the project from the designer.

I don’t see anything happening in the gateway logs as I do this. I’ve tried exporting and re-importing the project under a new name. When I tried running the gateway, this was in the logs

INFO   | jvm 1    | 2019/09/30 11:03:47 | I [Project                       ] [15:03:47]: Project [BBRC1] starting up... project-name=BBRC1
INFO   | jvm 1    | 2019/09/30 11:03:47 | I [C.BasicExecutionEngine        ] [15:03:47]: Modifying an existing execution unit. [Owner=named query cache maintenance, Name=bbrc1] project-name=BBRC1
INFO   | jvm 1    | 2019/09/30 11:03:47 | I [s.ProjectRunner               ] [15:03:47]: Project started. 
INFO   | jvm 1    | 2019/09/30 11:04:33 | I [P.InternalDatabase            ] [15:04:33]: Creating auto-backup of internal database "config.idb"... 
INFO   | jvm 1    | 2019/09/30 11:04:36 | I [P.InternalDatabase            ] [15:04:36]: Created auto-backup of internal database "config.idb" in 2 seconds 

but no project window appeared to log into. There are windows in the Vision project that are designated to open at start.

Any ideas?

Are you using a native client launcher or Java WebStart? If the latter, try the former.

If already using the native launcher, look in its log file to find the final java command that is trying to run the client. Copy that and paste it in a terminal. That terminal will then be the “console log” so you can see and report what is happening.

Was trying webstart. Will give this a shot.