Quality bad ignition to Modbus rtu

Hello Team,

May you lead me,
I have tried to connect Delta plc dvp20sx211 using USB to ignition 8.1.27 but I always read quality bad time out. I checked with KEPserverEx and receive data but not with ignition

I noticed that the time stamp is incorrect also 1/1/1601


Could you share the configuration for the communication

Does the USB interface show in the PC as a serial port? If not, Ignition won't support it. If it does, then you need to follow the instructions for Modbus RTU in IA's driver.

Yes, the USB is recognised as serial port,
I followed and double check what is written in the document but always failed

Regarding delta plc dvp20sx211:
. one USB port is for communicating with Isopsoft (delta plc IDE) ASCII, 9600,7,E,1 RS232
. One RS485 port, 9600,RTU, 8,N,1, I tried to connect it with KEPserverEx and works but have to specify ID address = 1

But with Ignition scada: COM4, 9600,RTU, 8,N,1 always bad quality

Specifying address == 1 is normal for Modbus RTU. Normal settings for Modbus RTU are 8-E-1 (per the Modbus specification). If using no parity, you must use two stop bits.

Ignition's driver defaults to address zero if not included in the OPC Item. So you must always include the 1. prefix yourself.

Also, Ignition does not support ASCII mode at all.

Good to know about parity, I am going to test it now. Thanks.

Where to add the prefix 1. about the address.

You have "Unit ID" set to zero in your address mapping. You said Kepware worked with unit ID 1.

(Consider not using mappings--they are only needed for browsing.)

IT WORKS, I have been dealing with it since two weeks, as a conclusion:
. Ignition can communicate with delta PLC through RS485/RS232 over USB (I use standard converter)
. Protocol config: RTU, 9600, E,1,
. Specify Unit ID inside address == 1

I like ignition support and philosophy. Thank you


1 Like