Quality: [Bad_NoDataAvailable]

Ignition 7.9.5. I created a new OPC tag, but the value is showing up as "null." When trying to read the configured tag from the quick client, I get the error "Quality: [Bad_NoDataAvailable] No data is currently available for reading from a non-blocking stream." However when I read directly from the device in the quick client, the data is showing correctly. I've tried disabling and re-enabling the device, but no luck. What am I missing?


Update: All new OPC tags have this behavior, regardless of what PLC I'm connecting to. All existing tags work correctly.

Maybe try restarting the gateway? That sounds pretty unusual.

Restarting the OPC-UA module fixed it. Thanks.

Don't forget to mark it as solved :slight_smile:

I'm facing this issue even after restarting the Gateway. Any other suggestions?

I'm using OPC UA Sever- OPC DA Sever- DeltaV Controller configuration using OPC Tunneler

Unable to clear this error. Any help would be appreciated.

Hello I have the same problem after restarting OPC UA module. I use an OPC Tuneller as well.