Quantum plc with 174 cev bridge

I have a quantum plc connected to my network using a 174 CEV 300 20 bridge. I have no problem accessing the plc over the network in proworx but i am having trouble connecting in ignition.

I have created a new connection using modbus v2/modbus rtu over tcp. I have tried creating tags with multiple configurations but everything I try the value of the tag is null. also the modbus light on the plc shows no activity at any point. typically when the device is being accessed with proworx the modbus light is active. Im not sure what im doing wrong here. this is the tag I thought would work: [Quantum]1.HR43044

any help would be greatly appreciated.

Try this instead:


Our address don’t use the (Modicon?) 3=IR, 4=HR prefixing scheme.

I have tried that as well but its still null. It seems as if the device is not responding to any requests - I would expect the modbus on the device to at least show some activity with all the different configurations I have tried.

Are you sure the unit ID is correct? Is it definitely RTU over TCP and not just TCP? Are there any errors in the console or does the read request just time out from lack of response?

yes its id is “1” - the bridge is just a modbus to ethernet but I have tried both RTU and TCP.

here is the log:

Uploaded with ImageShack.us

I’m not really sure there’s any additional trouble shooting you can do on the Ignition side. Is there someway you can verify that the traffic is going from the bridge to the PLC? Wireshark maybe?

The documentation for the bridge says you should be using Modbus TCP, not RTU over TCP.

Thank you - im up an running. I had read that and tried tcp prior but it didnt work, I did change the mb/tcp exception code setting in the bridge as well as the timeout from 3000 to 5000 - one of those must have been the issue. thanks again.