[Question] How do I activate the gateway Developer Mode?

My gateway is 8.1+ running with the trial license. I’m trying to activate Developer Mode so I don’t have to sign the .modl files before installing them.

Thank you!

1 Like

Hello Kevin,
I just found what you said in Ignition Maven Plugin v1.0.11 Fails - #3 by xasga and yes but I suspect I didn’t do it properly because my gateway isn’t in developer mode. This is what I added to (the 3rd line) .conf, I assumed it must follow the same pattern.

# Application parameters.  Add parameters as needed starting from 1
wrapper.app.parameter.1=com.inductiveautomation.catapult.Catapult
wrapper.app.parameter.2=Dia.developer.moduleupload=true

[edit] Dang it, I need to read more carefully…I didn’t set the parameter as Kevin said.

You need to follow the pattern (and use the same parameter name) as in Kevin’s linked post:
wrapper.java.additional.7=-Dignition.allowunsignedmodules=true

wrapper.app.parameter is the wrong section of the configuration file, D is the wrong prefix (should be -D), and ia.developer.moduleupload is the wrong flag.

Thank you Mr. Griffith.