Re-creating OEE Demo

Hello,

I have two gateways, one with the OEE Demo working without any problems. On the other gateway I Installed the OEE DT Module, but not the demo. I am writing from scratch an OEE Demo having the original demo as my guide.

I was able to configure the plant model (areas-lines-cells), I reproduced the product codes configuration screen (using the three table-components: ProductCodeTable, ProductCodeLineTable and ProductCodePropertiesTable) without problems.

But when I try to reproduce the screen “WorkOrder” and “WorkOrderEntry” I get some errors:
The “WorkOrderTable” is empty (I think it is OK since I have not yet entered any WO)
when I try to add a new order in the “WorkOrderEntry” screen, the ProductCode list is empty, and thats incorrect because I know there are product codes in my DB, and since I can’t select a Product Code, I cannot enter a new Work Order

When I look into the console logs I can see these errors:

and this other:

I tried re-starting the module, and the gateway but it’s still not working.
I thought that perhaps it needs at least one record in the WO table, so I entered one directly in the table but the WorkOrderTable is still empty.

Am I missing something?

For the product code selector are you choosing what line you want to select product codes from ? Also have the product codes in the database been linked to a particular line in the production model?

Hi James,
Thank you for your reply, Some hours ago I called to Tech-Support, and Luke Stone pointed me out that I was using the Track&trace module v.1.6.7 along with OEE Module v.1.6.6. and suggested me to upgrade OEE to v.1.6.7

I did that and now the problem is gone. All dropdowns and WO tables get populated correctly.

Thanks a lot for your help!