Read/write tags from ET200SP problem

Hi all,
I have Problem with read and write to a tags, I used ET200SP cpu and the Connection is done, but I still can’t read or write to a tags that connected to the unoptimised global DB, by the way the put and get also checkd by cpu configuration, so have any one idea About a solution for this Problem??


Hey Sarmad,

Have you tried checking the protection level?

I’m guessing you are using the S7 protocol, although that is not a bad choice, I would check if that CPU isn’t capable of running an embedded OPC-UA Server, that would make things smoother and safer for you.

Hi Sarmad,

up till now I didn’t have such troubles to R/W to ET200SP.
There are I guess two possibilities you can try:

  1. In CPU setting you set PUT/GET what is OK, just abow this tab is Access level.
    Acc. to Ignition recommendation the Full access without password must be set.
  2. In DB you can set three columns (default is set)
    Visibility from HMI/OPC UA
    Writeability from HMI/OPC UA
    Accessibility from HMI/OPC UA

Try to check both.


every Things is ok from cpu side!!

HMMM, strange.

If i know there is possible to use “S7-1200” and “S7-1500” CPU.
Do you use correct Ignition driver? I have no idea where is a difference but two different driver were issued.

Another thing is Firewall. Did you kill it? Or at least open port for Profinet?
I don’t remember port number… :crazy_face:

I have faced the simillar problem.
I used existing tag names connected in past to Schneider CPU with the same Device name just with different driver.

I have used A1_N1FX with Schneider PLC,
deleted this device,
created new one A1_N1FX with Siemens S7-1200,
changed Device name in Tag OPC configuration
it didn’t work

after I changed device name to A1_N1FX_SIE (other than former one) and changed it
in Tag OPC configuratin it start work well.

It looks strange but this way helped me to get working app.

thank you Radim for your Reply,
I tried to chnage the device Name and I delete evey Things and created again but it doesn’t work, the device connected but there are no read write,
I found the following :slight_smile:

the opc Server fault!!
I couldn’t know the reasons?
could you help?