Redirecting through Apache Proxy

In order to minimize the number of websites we have to navigate through we are trying to put the Ignition Web Admin behind our primary scada website as a proxy.

We are having problems with certain links on the Web Admin Interface. Namely the System | User Manual Link under the Configure Tab does not properly redirect for us.

Most other link on the site use relative paths like “…/config/system.backup” or some such and User Manual uses “/main/system/help” which for us does not redirect properly since it assumes an absolute path.

We use something like the following with the ip address altered.
ProxyPass /hmi
ProxyPassReverse /hmi

Most other links work in this configuration just not this link. Not sure if this is technically supported but would be nice if you could support hiding behind a proxy by using only relative paths in links.

Disclaimer: I don’t have extensive knowledge of proxies, so you’re officially on your own with this - i.e. you’re providing the expertise here.

Do the clients work at all through the proxy? Shouldn’t the proxy use url re-writing or something? It seems weird to me that you’d have to care about how the urls were formatted. I mean…we’re not the only website that uses absolute links, right? And as far as I know, there’s no general rule against them, so it seems that the proxy should be able to deal with them.

Try this with your IP address or hostname instead of I suspect main may be causing problems.

ProxyPass /hmi ProxyPassReverse /hmi

Thanks I had the settings correct for our system. While I could have /main included in the URL it does not help actually when I tried it apache totally failed due to an infinite substitution problem.

Anyway I suspect the problem is that you are using absolute paths in the URL for help and not a relative path like in the other links.

Everything works beautifully but that link with our configuration. I can download the designer and the jnlp files are all point at the correct servers. I can live with it for now and can actually probably fix the link in my apache config.

I worked around the problem temporarily by hardcoding the link in our apache configuration and assume that we will not happen to use that main url in our primary website which would cause some problems.
ProxyPass /main/system/help

Given that its unsupported thanks for the help in any case.

Well, I thought about this some more and was perplexed at the fact that your JNLP links worked, but the help link didn’t, because I thought they operated the same.

Turns out there was a slight tweak that I was able to make so that the help link uses a relative path. Sorry for the hassle. :blush:

It’ll be in 7.2