Redundancy - Cloud to Cloud and OPC Servers

I have a redundancy configuration where my servers are in different cloud networks and thus can’t resolve each other’s local IP addresses. So far this seems to be an issue only with the backup’s OPC connection to the internal Ignition OPCUA server. In the master I have the backup endpoint address to bind to set per the backup’s local IP, however in the OPC connection status on the backup it’s trying to bind to the local IP of the master (which it can’t resolve), not itself. Is this intended? Or is it possible I have a configuration issue still…

I thought the backup server would try to bind to its own Ignition OPCUA server, not that of the master…but maybe I’m wrong about that.


So, you changed the ‘Backup Endpoint Address’ in OPC UA Server -> Settings; did you make a corresponding change to the Backup Discovery URL/Backup Endpoint URL in the actual OPC-UA connection (OPC Connections -> Servers)?

1 Like

No I didn’t, my understanding may be wrong about the purpose there. I thought that was for pointing to a backup OPC server for that connection, not related to the redundant gateway. I’ll go have a look at that.

Thanks a ton for the quick reply.

Ok, that did the trick. Thanks! I’ll try to figure out where I missed the explanation on that part. It definitely wasn’t clear that it was related to Gateway redundancy, seemed solely to do with OPC server connection redundancy.

Much appreciated.

It’s a bit tricky - the ‘backup’ settings refer to Ignition’s redundancy, and the master/backup nodes. The ‘Failover’ settings just below dictate what happens when the connection itself faults.

1 Like

My next related issue are all my OPC server connections. Seems that non of the kepware OPC servers will connect to my backup gateway, only my IA OPC servers connect. Again I think I must be missing a config for this. Thoughts?

Where are the kepserver instance(s) running? Are they on the same server as the Ignition gateways, or on other cloud servers?

No, they are on other servers. I need to correct my statement now, some Kepservers are connecting fine, those that are not behind a NAT device. The ones not connecting are those that are behind a firewall that is handling NAT policies to forward the WAN IP and Port to the internal IP and port of the OPC server. I can actually browse the endpoints fine from the backup server, but it just won’t connect to them.

You may need to specify a ‘host override’ (and matching in the backup settings) to get past the NAT.

Yes, that is done on the master, otherwise they don’t work at all. I’ve checked that those settings have carried over to the backup. So I’m at a loss. May need to get some IA support eyes on it.

Looks like I messed up my settings. Just went through them again and I had the wrong IP address in the backup endpoint URL. I’m off to the races now. Thanks again!

1 Like